Задать вопрос
19 мая, 18:26

Из шестизначного числа выделить цифры и из них сформировать одномерный массив. Pascal

+4
Ответы (1)
  1. 19 мая, 22:07
    0
    Var a:longint;

    b: array[1 ... 6] of integer;

    i:integer;

    begin

    readln (a) ;

    for i:=6 downto 1 do

    begin

    b[i]:=a mod 10;

    a:=a div 10;

    end;

    {вывод массива}

    for i:=1 to 6 do

    writeln (b[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Из шестизначного числа выделить цифры и из них сформировать одномерный массив. Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Дан одномерный массив. Из элементов массива равных 100, сформировать массив b., а из элементов меньших 33, сформировать массив с.
Ответы (1)
Что такое одномерный массив в информатике? Для чего используется одномерный массив? Как описывается одномерный массив?
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)