Задать вопрос
3 сентября, 21:46

В данной последовательности целых чисел найти минимальное значение среди неотрицательных элементов и все номера членов последовательности, равных ему

на паскаль написать

+3
Ответы (1)
  1. 4 сентября, 01:40
    0
    Var a: array [1 ... 1000] of integer; i, n, min, amount: integer;

    begin

    read (n) ; {Сначала считываем кол-во элементов}

    for i : = 1 to n do

    read (a[i]) ;

    min : = 10000;

    amount : = 0;

    for i : = 1 to n do

    if (a[i] = 0) then

    min : = a[i];

    for i : = 1 to n do

    if a[i] = min then

    amount : = amount + 1;

    writeln ('Min: ', min, ', amount: ', amount) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В данной последовательности целых чисел найти минимальное значение среди неотрицательных элементов и все номера членов последовательности, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)