Задать вопрос
31 мая, 23:28

Составить программу, формирующую массив b[2], каждый элемент которого является максимальным из соответствующих элементов массивов а[4] и с[4]

+3
Ответы (1)
  1. 1 июня, 02:06
    0
    Var

    i:integer;

    a, c:array[1 ... 4]of integer;

    b:array[1 ... 2]of integer;

    begin

    write ('Массив а: ') ;

    for i:=1 to 4 do

    begin

    a[i]:=random (10) ;

    if a[i]>b[1] then b[1]:=a[i];

    c[i]:=random (10) ;

    if c[i]>b[2] then b[2]:=c[i];

    write (a[i],' ') ;

    end;

    writeln;

    write ('Массив c: ') ;

    for i:=1 to 4 do write (c[i],' ') ;

    writeln;

    write ('Массив b: ') ;

    for i:=1 to 2 do write (b[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, формирующую массив b[2], каждый элемент которого является максимальным из соответствующих элементов массивов а[4] и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. сформируйте массив содержащий 10 элементов с помощью датчика случайных чисел получить новый массив, каждый элемент которого равен сумме соответствующего элемента и его номера исходного массива. 2.
Ответы (1)
1) Ввести массив A из 25 элементов. Cформировать массив B из элементов массива А, кратных трем. 2) Даны массив A и B из n элементов. Cформировать массив C из элементов массивов А и B, чередуя элементы.
Ответы (1)
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)
Заполнить два массива (из 10 элементов каждый) случайными числами. Сформировать третий массив, каждый элемент которого равен полусумме соответствующих элементов исходных массивов.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)