Задать вопрос
28 июня, 12:59

Для фигур: равностороннего треугольника, квадрата, правильных 5-угольника, 6-угольника, ..., N-угольника дана длина стороны А (одна и та же). Вычислить площади S этих геометрических фигур. (Pasсal)

+3
Ответы (1)
  1. 28 июня, 13:46
    0
    Var

    a, S: real;

    n: integer;

    begin

    Write ('Введите через пробел длину стороны многоугольника и число сторон: ') ;

    Readln (a, n) ;

    S : = n * sqr (a) / (4 * tan (Pi / n)) ;

    Writeln ('Площадь многоугольника равна ', S:0:4) ;

    end.

    Тестовое решение:

    Введите через пробел длину стороны многоугольника и число сторон: 5 10

    Площадь многоугольника равна 192.3552
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Для фигур: равностороннего треугольника, квадрата, правильных 5-угольника, 6-угольника, ..., N-угольника дана длина стороны А (одна и та ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дана сторона квадрата а. Найти P = 4*a 2) Дана сторона квадрата а. Найти S = a^2 3) Даны стороны прямоугольника a и b. Найти его площадьS=a*b и периметр P = 2 * (a+b). 4) Дана длина ребра куба a.
Ответы (1)
В трехзначном числе х зачеркнули 1 цифру. Когда оставшиеся число умножили на 10, а произведение сложили с первой цифрой числа х, то получилось 564. Найти х. В Pasсal.
Ответы (1)
Написать программу по нахождению площадей геометрических фигур в паскале. Варианты фигур: квадрат, прямоугольный треугольник, круг, прямоугольник.
Ответы (1)
Чтобы украсить класс к 1 сентября, Даша и Саша вырезали из бумаги фигуры: осенний лист, цветок и звезду. Зная, что у них была только жёлтая и оранжевая бумага, посчитай, сколько получится разных вариантов фигур из бумаги. 1. 12 фигур 2. 9 фигур 3.
Ответы (1)
Написать программу решения следующей задачи: Составить программу, вычисляющую в зависимости от введённого признака n площадь одной из геометрических фигур: n=1 - квадрата, n=2 - трапеции, n=3 - круга, n=4 - прямоугольника.
Ответы (1)