Задать вопрос
23 мая, 12:12

Дан массив состоящий из 15 целых случайных чисел из промежутка от 10 до 30. Провести сортировку методом пузырька по убыванию

+5
Ответы (1)
  1. 23 мая, 15:22
    0
    Program enot;

    const m=15;

    var a: array[1 ... m] of integer;

    i, j, k: integer;

    begin

    for i : = 1 to m do

    a[i] : = random (21) + 10;

    for i : = 1 to m-1 do

    for j : = 1 to m-i do

    if a[j] < a[j+1] then begin

    k : = a[j];

    a[j] : = a[j+1];

    a[j+1] : = k

    end;

    write ('Отсортированный массив: ') ;

    for i : = 1 to m do

    write (a[i]:4) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив состоящий из 15 целых случайных чисел из промежутка от 10 до 30. Провести сортировку методом пузырька по убыванию ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)