Задать вопрос
15 марта, 09:14

Составить программу, которая проверяет правопис "жи", "ши" и выводит количество ошибок и исправленную строку

+2
Ответы (1)
  1. 15 марта, 11:19
    0
    Var

    a, count:longint;

    s:string;

    begin

    writeln ('введите строку') ;

    count:=0;

    read (s) ;

    while pos ('жы', s) >0 do

    begin

    inc (count) ;

    a:=pos ('жы', s) ;

    delete (s, a, 2) ;

    insert ('жи', s, a)

    end;

    while pos ('шы', s) >0 do

    begin

    inc (count) ;

    a:=pos ('шы', s) ;

    delete (s, a, 2) ;

    insert ('ши', s, a)

    end;

    writeln (s) ;

    writeln ('всего ошибок: ', count)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая проверяет правопис "жи", "ши" и выводит количество ошибок и исправленную строку ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Создайте программу которая проверяет правописание ча ща в строке и выводит на экран количество допущеных ошибок и исправленную строку
Ответы (1)
Составьте программу, которая позволяет проверить правописание "жи" и "ши" в тексте и выводит на экран количество допущенных ошибок и исправленную строку
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Помогите решить две задичи Задача: Написать программу, которая а) все буквы 'а' в строке st заменяет на букву 'о' и выводит новую строку на экран б) удаляет все буквы 'а' из строки и выводит новую строку на экран
Ответы (1)