Задать вопрос
2 июля, 20:03

Имеютися данные о среднемесячной температуре за год. Определите самую высокую и самую низкую температуры. Сколько месяцев в году было теплых (температура выше 0) через массивы

+3
Ответы (1)
  1. 2 июля, 23:26
    0
    Const N = 12;

    const k = 0;

    var temp : array [1 ... N] of integer;

    i, min, max, count : integer;

    begin

    min : = 1000; max : = - 1000;

    count : = 0;

    {Заполнение массива данными}

    for i : = 1 to N do

    begin

    write (i,'-й месяц: ') ;

    readln (temp[i]) ;

    if (temp[i] > max) then

    max : = temp[i];

    if (temp[i] < min) then

    min : = temp[i];

    {Если температура выше k - месяц считается теплым}

    if (temp[i] > k) then

    count : = count + 1;

    end;

    writeln ('Минимальная температура: ', min) ;

    writeln ('Максимальная температура: ', max) ;

    writeln ('Количество теплых месяцев: ', count) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Имеютися данные о среднемесячной температуре за год. Определите самую высокую и самую низкую температуры. Сколько месяцев в году было ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
тема: Структурный данный. Массивы. (Паскаль) Месяц 1 2 3 4 5 6 7 8 9 10 11 12 Темпреатура - 31 - 18 - 7.5 5.8 10 18 22.2 24 17 5.4 - 7 - 11 1) вычислите средние температуры зимних месяцев, весенних месяцев, летних месяцев и осенних месяцев.
Ответы (1)
Известны данные о среднемесячной температуре за год. Определить, какая была самая высокая температура летом и самая низкая зимой. Нужен код программы в паскаль.
Ответы (1)
1) Даны два массива A (10) и В (10) Нужно сформировать массив С (10) предварительно определив его длину, Включая из массивов А и В только четные по номеру элементов. И нужно вывести на экран массивы А (10), В (10), С (10).
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Составьте алгоритм, в котором вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних месяцев, осенних месяцев
Ответы (1)