Задать вопрос
20 декабря, 20:00

Паскаль. двухмерный массив.

В массиве B [1 ... 10,1 ... 3] содержатся данные о количестве сотрудников учреждения. Элементы первой строки обозначают номер отдела, элементы второй строки количество мужчин в нем, элементы третьей строки количество женщин в отделе. Сколько всего сотрудников в учреждении и кого больше: мужчин или женщин?

+5
Ответы (1)
  1. 20 декабря, 23:59
    0
    Var b:array[1 ... 10,1 ... 3] of integer;

    i, j, k, s, gi, bo:integer;

    begin

    writeln ('Исходный массив: ') ;

    for i:=1 to 10 do

    for j:=2 to 3 do b[i, j]:=random (30) ;

    k:=1;

    for i:=1 to 10 do begin

    for j:=1 to 3 do

    b[i, 1]:=k;

    inc (k) ;

    end;

    for i:=1 to 10 do begin

    for j:=1 to 3 do write (b[i, j]:5) ;

    writeln;

    end;

    for i:=1 to 10 do

    for j:=2 to 3 do

    s:=s+b[i, j];

    write (' Всего сотрудников в учреждении: ', s) ;

    for i:=1 to 10 do

    gi:=gi+b[i, 2];

    write (' Женщин в учреждении: ', gi) ;

    for i:=1 to 10 do

    bo:=bo+b[i, 3];

    write (' Мужчин в учреждении: ', bo) ;

    if (gi>bo) then write (' женщин больше')

    else write (' мужчин больше') ;

    if (gi=bo) then write (' женщин и мужчин одинаковое количество') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. двухмерный массив. В массиве B [1 ... 10,1 ... 3] содержатся данные о количестве сотрудников учреждения. Элементы первой строки ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Расписать, почему Вы сделали тот или иной выбор. На фирме "Ромашка" ровно треть сотрудников составляют менеджеры, ровно треть - разнорабочие и ровно треть - инженеры.
Ответы (1)
1. Дан двухмерный массив A (n, m). Найти произведение отрицательных четных элементов второго столбца массива. 2. Дан двухмерный массив m*n. Получите одномерный массив b, элементы которого равны min элементам по строкам.
Ответы (1)
PascalABC 1. Задан массив А (N). Получить из него массив В, состоящий из элементов массива А, значения которых больше 0. 2. Задан двухмерный массив целых чисел A[N, M]. Найти строки, содержащие нулевые элементы.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Дан двухмерный массив "у" с размерностью n x m если все элементы строки четные, то вывести порядковый номер строки. в паскале написать программу
Ответы (1)