Задать вопрос
2 июля, 07:07

Нужно написать программу на языке паскаль по условию:

Найти сумму элементов массива расположенных до последнего положительного элемента

Буду бескрайне благодарна, если поможете мне))

+5
Ответы (1)
  1. 2 июля, 09:26
    0
    Uses crt;

    var a, b:array[1 ... 100] of integer; i, j, k, n:integer;

    procedure rmassr;

    begin

    for i:=1 to n do begin

    a[i]:=random (10) ;

    end;

    end;

    procedure rmassy;

    begin

    for i:=1 to n do begin

    readln (a[i]) ;

    end;

    end;

    procedure rmass () ;

    begin

    for i:=1 to n do begin

    write (a[i],' ') ;

    end;

    end;

    procedure newmass;

    begin

    for i:=1 to n do begin

    if a[i] > 0 then b[i]:=a[i];

    end;

    for i:=1 to n do begin

    j:=j+b[i];

    end;

    writeln ('summa = ', j) ;

    end;

    begin

    clrscr;

    randomize;

    write ('длина массива ') ; readln (n) ;

    write ('1-random; 2-в ручную') ; readln (k) ;

    if k = 1 then

    rmassr ()

    else rmassy () ;

    rmass () ;

    writeln () ;

    newmass () ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно написать программу на языке паскаль по условию: Найти сумму элементов массива расположенных до последнего положительного элемента ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Помогите откорректировать программу - Паскаль. Структура программы как у меня. Условие: Дан одномерный массив, состоящий из вещественных элементов. Найти сумму элементов массива, расположенных до последнего положительного элемента.
Ответы (2)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)