Задать вопрос
4 ноября, 07:57

В упорядоченном по не убыванию одномерном массиве чисел определить, есть ли заданное число W, в противном случае подсчитать количество чисел, меньших W, кроме того, вычислить произведение положительных чисел массива.

+1
Ответы (2)
  1. 4 ноября, 08:46
    0
    Помочь:? если нужно олрллрло
  2. 4 ноября, 10:11
    0
    Var a:array[1 ... 10]of integer;

    i, w, p, k, j:integer;

    begin

    read (w) ; p:=1;

    for i:=1 to 10 do read (a[i]) ;

    for i:=1 to 10 do begin

    if (a[i]=w) then break

    else begin

    for j:=1 to 10 do begin

    if (a[j]
    end; writeln (k) ; end; end;

    for i:=1 to 10 do begin

    if (a[i]>0) then p:=p+a[i];

    end; writeln (p) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В упорядоченном по не убыванию одномерном массиве чисел определить, есть ли заданное число W, в противном случае подсчитать количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1) В числовом одномерном массиве все элементы массива, кратные 3, возвести в куб. В новом массиве найти сумму всех членов массива.
Ответы (1)