Задать вопрос
5 мая, 12:57

Введите два числа А и В. Проверьте, есть ли у них одинаковые цифры.

+2
Ответы (1)
  1. 5 мая, 15:04
    0
    var

    s, s1: string;

    i: integer;

    begin

    readln (i) ;

    s : = IntToStr (i) ;

    readln (i) ;

    s1 : = IntToStr (i) ;

    for i : = 1 to length (s) do

    if (pos (s[i], s1) > 0) then

    s1 : = '-'; if (s1 = '-') then

    writeln ('Yes')

    else

    writeln ('No') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Введите два числа А и В. Проверьте, есть ли у них одинаковые цифры. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны 3 стороны треугольника АВС-напечатать какой имеет вид треугольник. Проверьте где у меня ошибки: var a, b, c:integer; begin write ('введите a=') ; readln (a) write ('введите b=') ; readln (b) write ('введите c=') ;
Ответы (1)
Помогите составить программы Введите несколько чисел. Найдите произведение чисел меньших 7. Введите несколько чисел. Найдите количество двузначных чисел. Введите несколько чисел.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите целое число: Введите целое число: 1232 1224 Нет. Да. Через ветвление, while, repeat, until
Ответы (1)
Python. Уровень B. Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите натуральное число: 12342 Нет. Пример: Введите натуральное число: 12245 Да.
Ответы (1)