Задать вопрос
8 декабря, 20:31

Решить задачу по информатике. В пяти тестовых опросах мальчик получил оценки. Составьте алгоритм и программу которая определит средние значение оценок полученных мальчиком в пяти опросах

+4
Ответы (1)
  1. 9 декабря, 00:27
    0
    Везде значения вводятся с клавиатуры!

    на java

    если изучали массив:

    public class qwert {

    public static void main (String args[]) {

    Scanner scn = new Scanner (System. in) ;

    int[] a = new int[5];

    int k = 0;

    for (int i = 0; i < 5; i++) {

    a[i] = scn. nextInt () ;

    k = k + a[i];

    if (i = = 4)

    System. out. println (k/i) ;

    }

    } }

    если не изучали массив:

    public class qwert {

    public static void main (String args[]) {

    Scanner scn = new Scanner (System. in) ;

    int a = scn. nextInt () ;

    int b = scn. nextInt () ;

    int c = scn. nextInt () ;

    int d = scn. nextInt () ;

    int e = scn. nextInt () ;

    int s = (a + b + c + d + e) / 5;

    System. out. println (s) ;

    } }

    на паскале через массив:

    var a:array [1 ... 5] of integer;

    i:integer;

    s:real;

    begin

    for i : = 1 to 5 do

    begin

    readln (a[i]) ;

    s : = s + a[i];

    if i = 5

    then

    write (s/i) ;

    end;

    end.

    не через масивы:

    var a, b, c, d, e : integer;

    s:real;

    begin

    readln (a, b, c, d, e) ;

    s : = (a+b+c+d+e) / 5;

    write (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить задачу по информатике. В пяти тестовых опросах мальчик получил оценки. Составьте алгоритм и программу которая определит средние ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вася за 1 четверть получил по информатике 20 оценок. Чтобы вычислить какую оценку он получит необходимо найти среднее арифметическое этих оценок. Напишите программу для нахождения среднего арифметического оценок.
Ответы (1)
Известны оценки по информатике ученика Сидорова Васи. В начале списка перечислены все пятерки, затем все остальные оценки. Сколько Вася имеет по информатике оценок "5"?. Условный оператор не использовать. Использовать цикл Repeat
Ответы (1)
Составить программу оценки на соревнованиях по фигурному катанию выставляются 9 судьями. потом одна самая высокая и самая низкие оценки отбрасываются и в зачет идет среднее арифметическое оставшихся оценок.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
исключи из предложенных сочетаний слов те, которые невозможны в информатике: 1) линейный алгоритм 2) прямой алгоритм 3) циклический алгоритм 4) разветвляющийся алгоритм
Ответы (2)