Задать вопрос
18 февраля, 16:33

Найти сумму корней квадратных из трёхзначных натуральных чисел.

Создайте прогу которая просчитывала это на ABCpascal

+1
Ответы (1)
  1. 18 февраля, 19:53
    0
    Var

    a, b, c : integer;

    d, x1, x2, s : real;

    begin

    writeln ('ax^2+bx+c=0') ;

    write ('a=') ;

    readln (a) ;

    write ('b=') ;

    readln (b) ;

    write ('c=') ;

    readln (c) ;

    d : = sqr (b) - 4 * a * c;

    if d < 0 then

    writeln ('Корней нет')

    else

    begin

    x1 : = (-b + sqrt (d)) / (2*a) ;

    x2 : = (-b - sqrt (d)) / (2*a) ;

    if x1 x2 then

    begin

    writeln ('x1=', x1) ;

    writeln ('x2=', x2) ;

    s : = x1+x2;

    writeln ('s=', s) ;

    end

    else

    writeln ('x=s=', x1) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму корней квадратных из трёхзначных натуральных чисел. Создайте прогу которая просчитывала это на ABCpascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Сделать программу ABCpascal Даны 2 числа если оба числа отрицательные то найти корень из деления иначе увеличить первое в 3 раза а второе на 7
Ответы (1)
Помогите! Напишите программу, которая в последовательности натуральных чисел определяет количество трехзначных чисел, кратных 4.
Ответы (1)
1 вариант. 1. Найти сумму и произведение первых 6 последовательных натуральных чисел. 2. Найти сумму первых k последовательных нечетных чисел. 3. Вывести на экран натуральные нечётные числа от 5 до 55. 4.
Ответы (1)
Сахарная свекла содержит 14% сахара с 1 га собирают 35 т сахарной свеклы сколько надо засеять сахарной свеклой чтобы получить В т сахара 7 Класс В ABCpascal
Ответы (1)