Задать вопрос
28 декабря, 20:50

Сделать процедуру максимума и минимума 3 чисел, и их сумму. В паскале

+1
Ответы (1)
  1. 28 декабря, 23:23
    0
    Procedure maxminsum (a, b, c:real) ;

    var

    sum, max, min:real;

    begin

    if (a>b) and (a>c) then max:=a;

    if (b>a) and (b>c) then max:=b;

    if (c>b) and (c>a) then max:=c;

    if (a
    if (b
    if (c
    sum:=a+b+c;

    writeln ('max = ', max) ;

    writeln ('min = ', min) ;

    writeln ('sum = ', sum) ;

    end;

    var a, b, c:real;

    begin

    readln (a, b, c) ;

    maxminsum (a, b, c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сделать процедуру максимума и минимума 3 чисел, и их сумму. В паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать в Паскале процедуру с изменяемым параметром. помогите хотя бы с одним. Уровень A. Напишите процедуру, которая переставляет три переданные ей числа в порядке возрастания. Пример: Введите три натуральных числа: 10 15 5 5 10 15 Уровень B.
Ответы (1)
Помогите решить. Даны действительные a, b, c. Используя процедуру поиска максимума двух чисел max и минимума двух чисел min, получить: min (3a, a+b, 7c) + max (a+b, b+c) С объяснением (паскаль абс)
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Описать процедуру SumDigit (N, S), находящую сумму цифр S целого числа N (N - входной, S - выходной параметр). Используя эту процедуру, найти суммы цифр пяти данных чисел.
Ответы (1)
1 Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров , в каком из двух введенных с клавиатуры целых чисел произведение цифр больше.
Ответы (1)