Задать вопрос
2 января, 15:24

Надо решить задачу используя алгоритмическую структуру "цикл" : Найти все трехзначные числа сумма цифр которых равна 8.

+1
Ответы (1)
  1. 2 января, 18:57
    0
    Var i, t, s:integer;

    Begin

    For i:=100 to 999 do

    Begin

    t:=i; s:=0;

    While t>0 do

    Begin

    s:=s+t mod 10;

    t:=t div 10;

    End;

    if s=8 then write (i,' ') ;

    End;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Надо решить задачу используя алгоритмическую структуру "цикл" : Найти все трехзначные числа сумма цифр которых равна 8. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
В каком типе цикла тело цикла выполняется пока условие ложно? А) цикл со счетчиком Б) цикл с постусловием В) цикл с предусловием Г) цикл с рекурсией
Ответы (1)
Решить задачу, используя "цикл с параметром", "цикл с предусловием", "цикл с постусловием". Найти сумму и произведение первых n натуральных чисел.
Ответы (1)
Как решить задачу по информатике моделированию макаровой составить алгоритмическую модель умножения двух чисел Аи В с определением знака произведения
Ответы (1)
3) Определите, сколько раз исполнится цикл:for i:=0 to 8 do write (i) ; A) Цикл будет бесконечным B) Вообще не исполнится C) 8 раз D) 9 раз 4) Определите, сколько раз исполнится цикл:for i:=-10 downto 0 do write (i) ;
Ответы (1)