Задать вопрос
29 октября, 21:10

Для того чтобы выходить в Интернет, каждому компьютеру присваивается так называемый IP-адрес. Он состоит из четырех целых чисел в диапазоне от 0 до 255, разделенных точками. В следующих трех строках показаны три правильных IP-адреса:

127.0.0.0

192.168.0.01

255.00.255.255

Напишите программу, которая определяет, является ли заданная строка правильным IP-адресом.

Формат входного файла:

На вход программе подается строка длиной не более 15 символов, которая включает цифры и ровно три точки.

Формат выходного файла:

Если строка является правильным IP-адресом, необходимо вывести 1, иначе 0.

+4
Ответы (1)
  1. 30 октября, 00:47
    0
    Program ip;

    var s, s1:string;

    i, j, x, err:integer;

    f:boolean;

    begin

    readln (s) ;

    i:=1; j:=1; f:=true;

    while (j<4) and f do

    begin

    while s[i]'.' do

    begin

    s1:=s1+s[i];

    inc (i) ;

    end;

    val (s1, x, err) ;

    f:=x<256;

    delete (s1,1, length (s1)) ;

    inc (j) ;

    end;

    if f then

    begin

    while i<=length (s1) do

    begin

    s1:=s1+s[i];

    inc (i) ;

    end;

    f:=x<256;

    end;

    if f then writeln (1) else writeln (0) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Для того чтобы выходить в Интернет, каждому компьютеру присваивается так называемый IP-адрес. Он состоит из четырех целых чисел в диапазоне ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Какие из последовательностей могут быть масками? 255.255.255.122 255.255.128.255 255.255.156.0 255.255.255.192 255.255.224.192 255.255.255.128 255.255.128.128 255.255.128.0 255.255.255.102 255.255.248.0
Ответы (1)
Задача W. Сумма двух чисел Имя входного файла: sum. in Имя выходного файла: sum. out Ограничение по времени: 2 секунды Ограничение по памяти: 256 мегабайт Формат входного и выходного файла На первой строке входного файла находятся два целых числа a
Ответы (1)
Какие из этих пар IP-адресов являются локальными, если маска подсети 255.255.255.0? (укажите несколько вариантов ответа) 1) 192.37.65.3 и 192.37.66.3 2) 192.35.43.15 и 192.35.43.20 3) 192.2.3.4 и 192.2.3.6 4) 192.35.42.10 и 192.36.42.200 5) 192.37.
Ответы (1)
Имя входного файла:E. in имя выходного файла E. out Дается ... Имя входного файла:E. in имя выходного файла E. out Дается последовательность из N чисел. найдите максимальное произ. среди всех пар этих чисел.
Ответы (1)
Формат входного и выходного файла На первой строке входного файла находятся два целых числа a и b (-109 ≤ a, b ≤ 109 ). Вашей программе требуется вывести единственное число - сумму заданных чисел a + b.
Ответы (1)