Задать вопрос
23 августа, 04:08

Даны четыре слова одинаковой длины. напечатать сообщение о наличии или отсутствии одинаковых слов и это слово (в программе pascal)

+5
Ответы (1)
  1. 23 августа, 08:05
    0
    Var

    s1, s2, s3, s4:string;

    k:integer;

    begin

    writeln ('Введите 1 слово:') ;

    readln (s1) ;

    writeln ('Введите 2 слово:') ;

    readln (s2) ;

    writeln ('Введите 3 слово:') ;

    readln (s3) ;

    writeln ('Введите 4 слово:') ;

    readln (s4) ;

    writeln ('Список одинаковых слов') ;

    if (s1=s2) or (s1=s3) or (s1=s4) then begin k:=1; writeln (s1) ; end;

    if (s2=s3) or (s2=s4) then begin k:=1; writeln (s2) ; end;

    if s3=s4 then begin k:=1; writeln (s3) ; end;

    if k=0 then writeln ('Одинаковых слов нет') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны четыре слова одинаковой длины. напечатать сообщение о наличии или отсутствии одинаковых слов и это слово (в программе pascal) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Решить в СИ! Даны три действительных числа. Возвести в квадрат и напечатать те из них, значения которых неотрицательны. Если таковых нет, то напечатать сообщение
Ответы (1)
Составить программу в Pascal, используя цикл с счетчиком for 1. Напечатать квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b>10) 2. Напечатать все целые числа от a до b (значения a и b вводятся с клавиатуры)
Ответы (1)