Задать вопрос
12 октября, 03:15

Написать программу в Pascal, используя массивы.

Дано массив А[1 ... n]. Сделать программу которая выводит те элементы массива? индексы которых являются степени двойки

Желательно с обьяснением строк

+2
Ответы (1)
  1. 12 октября, 07:06
    0
    Const

    n = 100;

    var

    a: array[1 ... n] of integer;

    i: integer;

    begin

    //заполняем массив случайными значениями в диапазоне [0; 100]

    Randomize; / / инициализация датчика случайных чисел

    for i : = 1 to n do a[i] : = random (100) ;

    i : = 1; / / 1 - это два в нулевой степени

    while i < n do

    begin

    writeln ('a (', i, ') = ', a[i]) ;

    i : = 2 * i; / / удваиваем индекс, чтобы получить очередную степень двойки

    end

    end.

    Результат работы программы:

    a (1) = 26

    a (2) = 21

    a (4) = 29

    a (8) = 74

    a (16) = 23

    a (32) = 44

    a (64) = 20
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в Pascal, используя массивы. Дано массив А[1 ... n]. Сделать программу которая выводит те элементы массива? индексы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите с информатикой 1. Что такое массив? 2. Что такое элемент массива? 3. Что такое индекс массива? 4. Что такое размерность массива? 5. Зачем нужны массивы? 6. Как можно обратиться к ячейке массива? 7. Какого типа могут быль элементы массива? 8.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)