Задать вопрос
16 октября, 20:57

Нужно создать программу на языке програмирования паскаль, чтобы вводить сведения о авто (вводить марку) а программа выдавала сведения о ее хозяине (программа выдает номер авто и фамилию хозяина)

задача:

Сведения об автомобиле состоят из его марки, номера и фамилии владельца. Дана файл f, содержащий сведения о нескольких автомобилях. Найти фамилии влвдельцев и номера автомобилей по данной марки

+2
Ответы (1)
  1. 16 октября, 21:33
    0
    Ничего не сказано о структуре файла f. Предположим, что данные в нем хранятся в виде записей с полями:

    model - марка автомобиля

    nomer - номер

    name - фамилия

    Сам файл имеет полное имя d:/car. txt

    Тогда программа будет иметь вид:

    type

    tcar=record

    model:string;

    nomer: string;

    name: string;

    end;

    var

    f:file;

    car: tcar;

    m:string;

    begin

    assign (f,'d:/car. txt') ;

    reset (f) ;

    write ('Введите марку машины: ') ;

    read (m) ;

    while not eof (f) do

    begin

    read (f, car) ;

    if m=car. model then

    writeln (car. name,' ', car. nomer) ;

    end;

    close (f) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно создать программу на языке програмирования паскаль, чтобы вводить сведения о авто (вводить марку) а программа выдавала сведения о ее ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите сделать программу в Паскале В котором 1) Программа выдает сообщение "Вы маль или дево" 2) Пользователь в переменную ST1 задает значение маль или дево 3) Программа выдает сооб "Ты пошла бы играть в куклы" 4) Вводить ответ через переменную
Ответы (1)
Почему файл, созданный в Word 2007, имеет расширение. docm? Вариант 1 файл предназначен для пересылки по электронной почте Вариант 2 файл содержит вирусы Вариант 3 файл создан на основе шаблона Вариант 4 файл содержит макросы
Ответы (1)
Сравнение файлов Первый файл на 1 мегабайт больше, чем второй файл. Второй файл на 3072 байта больше, чем третий файл. На сколько килобайт третий файл меньше, чем первый? В ответе укажите только число, слово "килобайт" писать не надо.
Ответы (1)
Фоксфорд олимпиада по информатикеПервый файл на 1 мегабайт больше, чем второй файл. Второй файл на 3072 байта больше, чем третий файл. На сколько килобайт третий файл меньше, чем первый? В ответе укажите только число, слово "килобайт" писать не надо.
Ответы (1)
Создать текстовый файл f1. Конкатенировать файл f 1 самого с собой, только записанного задом наперед и результат записать в файл f2. Вывести на экран файл f 2.
Ответы (1)