Задать вопрос
5 апреля, 13:20

Вводится натуральное число N (N<10000) Выяснить, верно ли, что в его записи все цифры различны?

+1
Ответы (1)
  1. 5 апреля, 14:57
    0
    Program gt;

    var a:array[1 ... 10]of integer;

    p, n, i:integer;

    begin

    readln (n) ;

    p:=0;

    while n>0 do

    begin

    inc (a[n mod 10]) ;

    n:=n div 10;

    if (a[n mod 10]>1) then p:=1;

    end;

    if (p=1) then writeln ('NO') else writeln ('YES') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводится натуральное число N (N ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
С клавиатуры вводится натуральное число k, затем последовательно вводится k чисел с плавающей точкой. Найти сумму этих чисел и наименьшее них. Паскаль ...
Ответы (1)