Задать вопрос
5 декабря, 04:45

Выполнить переворот или сортировку массива с помощью процедур (pascal abc).

+5
Ответы (1)
  1. 5 декабря, 07:24
    0
    Const

    nm = 100;

    type

    Mas = array[1 ... nm] of integer;

    procedure Shell (var a: Mas; n: integer) ;

    { сортировка методом Шелла }

    var

    i, j, step, t: integer;

    begin

    step : = n div 2;

    while step > 0 do

    begin

    for j : = n - step downto 1 do

    begin

    i : = j;

    while i < = n - step do

    begin

    if a[i] > a[i + step] then

    begin

    t : = a[i];

    a[i] : = a[i + 1];

    a[i + 1] : = t

    end;

    i : = i + step

    end

    end;

    step : = step div 2

    end

    end;

    var

    x: Mas;

    i, n: integer;

    begin

    Randomize;

    Write ('Введите число элементов в массиве (1-100) : ') ;

    Readln (n) ;

    Writeln ('Исходный массив') ;

    for i : = 1 to n do

    begin

    x[i] : = Random (101) - 50;

    Write (x[i]:4)

    end;

    Shell (x, n) ;

    Writeln (#13#10, 'Отсортированный массив') ;

    for i : = 1 to n do Write (x[i]:4)

    end.

    Тестовое решение:

    Введите число элементов в массиве (1-100) : 20

    Исходный массив

    -8 - 17 - 19 1 - 3 23 - 33 30 - 27 - 45 12 26 - 24 18 37 8 47 - 14 - 19 - 3

    Отсортированный массив

    -45 - 33 - 27 - 24 - 19 - 19 - 17 - 14 - 8 - 3 - 3 1 8 12 18 23 26 30 37 47
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Выполнить переворот или сортировку массива с помощью процедур (pascal abc). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите с информатикой 1. Что такое массив? 2. Что такое элемент массива? 3. Что такое индекс массива? 4. Что такое размерность массива? 5. Зачем нужны массивы? 6. Как можно обратиться к ячейке массива? 7. Какого типа могут быль элементы массива? 8.
Ответы (1)
Pascal ABC Напишите программу, которая находит три наименьших элемента массива и переставляет их в начало массива. Остальные элементы должны следовать далее в том же порядке. Входные данные Первая строка содержит размер массива N.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)