Задать вопрос
21 августа, 10:43

1 задача.

Сколько существует целых

положительных чисел, меньших 512₁₀,

в двоичной записи которых

встречается не менее шести единиц подряд?

В ответе укажите целое число.

2. задача. Модему, передающему информацию со

скоростью 512 байт/c,

потребовалось

1 минута и 4 секунды для того, чтобы передать растровое

изображение. Укажите максимальное количество цветов в палитре изображения, если

известно, что его размер составил 128x256 пикселей. Ответ запишите в виде

целого числа.

+2
Ответы (1)
  1. 21 августа, 14:18
    0
    Program gt;

    var a:array[1 ... 100]of integer;

    k, q, p, i, max:integer;

    begin

    for i:=1 to 512 do

    begin

    p:=i;

    max:=0;

    K:=0;

    while p>0 do

    begin

    q:=p mod 2;

    p:=p div 2;

    if (q=1) then k:=k+1;

    if (q=0) then begin

    if (k>max) then max:=k;

    k:=0;

    end;

    end;

    if (max>=6) then writeln (i) ;

    end;

    end.

    191

    319

    382

    383

    447

    2)

    размер 512 байт / c*64c = 32768 байт

    в изображении - 32768 пикселей

    значит на пиксель отведен 1 байт памяти или 8 бит значит палитра 2^8 цветов или 256
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1 задача. Сколько существует целых положительных чисел, меньших 512₁₀, в двоичной записи которых встречается не менее шести единиц подряд? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Модему, передающему информацию со скоростью 512 байт/c, потребовалось 1 минута и 4 секунды, для того чтобы передать растровое изображение.
Ответы (2)
Сколько секунд потребуется модему, придававшему сообщение со скоростью 14400 бит/сек чтобы передать растровое изображение размером 800*600 пикселей, при условие, что в палитре 16 миллионов цветов?
Ответы (1)
Cколько потребуется модему, передающему сообщения с скоростью 14400 бит/сек, чтобы передать цветное растровое изображение с размером 800x600 пикселей, при условии, что в палитре 16 миллионов цветов?
Ответы (1)
Сколько секунд потребуется модему, передающему информацию со скоростью 14 400 бит/с, чтобы передать цветное растровое изображение размером 800 х600 пикселей, при условии, что в палитре 256 цветов. Результат представьте целым числом.
Ответы (1)
1. Сколько бит потребуется для кодирования цветовой палитры из 2048 цветов? 2. Какой объем видеопамяти в КБайтах необходим для хранения пяти страниц изображения, если битовая глубина равна 12, а размер изображения 256 x 512 пикселей? 3.
Ответы (1)