Задать вопрос
9 января, 13:05

составить программу которая будет находить сумму отрицательных чётных элементов одномерного массива. используя процедуры

+1
Ответы (1)
  1. 9 января, 13:35
    0
    Var

    i, s:integer;

    a:array[1 ... 10]of integer;

    procedure sum (a:integer; var s:integer) ;

    begin

    if (a mod 2=0) and (a<0) then

    s:=s+a

    end;

    begin

    write ('Массив: ') ;

    for i:=1 to 10 do

    begin

    a[i]:=random (-10,10) ;

    write (a[i],' ') ;

    sum (a[i], s)

    end;

    writeln;

    writeln ('s=', s)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу которая будет находить сумму отрицательных чётных элементов одномерного массива. используя процедуры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)