Задать вопрос
15 апреля, 15:13

Помогите составить программу

Вычислить время T встречи автомобилей, движущихся равноускоренно навстречу друг другу, если известны их скорости V1, V2, ускорения a1, a2 и начальное расстояние S между ними.

+5
Ответы (1)
  1. 15 апреля, 16:08
    0
    var V1, V2, a1, a2, S, T:real;

    begin

    writeln ('Введите начальные скорости автомобилей') ;

    read (V1, V2) ;

    writeln ('Введите ускорения автомобилей') ;

    read (a1, a2) ;

    writeln ('Введите начальное расстояние между автомобилями') ;

    read (S) ;

    T:=abs ((- (V1 + V2)) + sqrt (sqr (V1 + V2) + (a1+a2) * 2*s) / (a1+a2)) ;

    writeln (T) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите составить программу Вычислить время T встречи автомобилей, движущихся равноускоренно навстречу друг другу, если известны их ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
На предприятии имеется N1=8 автомобилей ГАЗ, N2=5 автомобилей ЗИЛ, N3=6 автомобилей КаМАЗ, N4=3 автомобилей MAN. Какое количество информации несет сообщение о выезде с территории автомобиля каждого вида?
Ответы (1)
На предприятии имеется 2 автомобилей ГАЗ, 6 автомобилей ЗИЛ, 6 автомобилей КаМАЗ, 3 автомобилей MAN. Какое количество информации несет сообщение о выезде с территории автомобиля каждого вида?
Ответы (1)
На предприятии имеется N1=5 автомобилей ГАЗ, N2=6 автомобилей ЗИЛ, N3=4 автомобилей КаМАЗ, N4=5 автомобилей MAN. Какое количество информации несет сообщение о выезде с территории автомобиля каждого вида?
Ответы (1)
На предприятии имеется 8 автомобилей ГАЗ, 4 автомобилей ЗИЛ, 4 автомобилей КаМАЗ, 8 автомобилей MAN. Какое количество информации несет сообщение о выезде с территории автомобиля каждого вида?
Ответы (1)