Задать вопрос
22 июля, 09:22

Напишите программу, которая вводит трехзначное число и разбивает его на цифры. Пример: при вводе числа 123 программа должна вывести "1, 2, 3"

+4
Ответы (1)
  1. 22 июля, 11:10
    0
    Var numb, sot, des, ed:integer;

    begin

    readln (numb) ;

    sot:=numb div 100;

    des: = numb mod 100;

    des: = des div 10;

    ed: = numb mod 10;

    writeln (sot,' ', des,' ', ed) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая вводит трехзначное число и разбивает его на цифры. Пример: при вводе числа 123 программа должна вывести "1, 2, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
10. Составить программу, осуществляющую ввод числовых переменных. При вводе положительного числа вывести информацию: "Число больше ноля", при вводе отрицательного числа - "Число меньше ноля", при вводе ноля - "Вы ввели ноль".
Ответы (1)
Составить программу, осуществляющую ввод числовых переменных. При вводе положительного числа вывести информацию: "Число больше ноля", при вводе отрицательного числа - "Число меньше ноля", при вводе ноля - "Вы ввели ноль".
Ответы (1)
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)
3. Напишите и выполните программу на компьютере a. Программа вводит одно число, и вычисляет его квадрат, вычитая из него удвоенное значение введенного числа. b. Программа вводит два числа, выводит сумму квадратов этих чисел минус их произведение. c.
Ответы (1)
1) Напишите программу, которая вводит натуральное число N и нахо дит сумму всех натуральных чисел от 1 до N. Используйте сначала цикл с условием, а потом - цикл с переменной.
Ответы (1)