Задать вопрос
23 мая, 12:54

Напишите функцию, которая вычисляет наибольший общий делитель двух чисел

+5
Ответы (1)
  1. 23 мая, 16:31
    0
    Function NOD (a, b: Integer) : Integer;

    Var tmp, r: Integer;

    Begin

    If b > a Then

    Begin

    tmp : = a;

    a : = b;

    b : = tmp;

    End;

    tmp : = a;

    While tmp > 0 Do

    Begin

    Result : = tmp;

    tmp : = tmp - b;

    End;

    End;

    Пример программы с использованием данной функции:

    Program Example;

    Var a, b: Integer;

    Function NOD (a, b: Integer) : Integer;

    Var tmp, r: Integer;

    Begin

    If b > a Then

    Begin

    tmp : = a;

    a : = b;

    b : = tmp;

    End;

    tmp : = a;

    While tmp > 0 Do

    Begin

    Result : = tmp;

    tmp : = tmp - b;

    End;

    End;

    Begin

    Write ('a = ') ;

    ReadLn (a) ;

    Write ('b = ') ;

    ReadLn (b) ;

    Write ('НОД: ', NOD (a, b)) ;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите функцию, которая вычисляет наибольший общий делитель двух чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.
Ответы (1)
1. Написать функцию, которая вычисляет минимум из четырёх чисел. 2. Написать функцию, которая вычисляет минимум из двух чисел. В чём ошибка? 1.
Ответы (1)
1. Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры. 2. Напишите функцию, которая находит наибольший общий делитель для двух заданных чисел.
Ответы (1)
Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры. Напишите функцию, которая находит наибольший общий делитель для двух заданных чисел.
Ответы (1)
Написать программу, которая вычисляет наибольший общий делитель двух целых чисел Паскаль
Ответы (1)