Задать вопрос
4 июня, 09:02

Напишите программу в Паскале и объясните, как это делается

Сложить два 15-ти значных целых числа. При этом используют тип integer. Т. е. реализовать поэлементное сложение значений двух массивов с переносом разряда.

+4
Ответы (1)
  1. 4 июня, 11:24
    0
    Const n=15;

    var a, b, c:array[0 ... n] of integer;

    s_a, s_b:string;

    i:integer;

    Begin

    readln (s_a) ;

    readln (s_b) ;

    while length (s_a)
    while length (s_b)
    for i : = n downto 1 do begin

    a[i]:=strtoint (s_a[i]) ;

    b[i]:=strtoint (s_b[i]) ;

    c[i]:=c[i]+a[i] + b[i];

    c[i-1]:=c[i] div 10;

    c[i]:=c[i] mod 10;

    end;

    writeln;

    for i: = 0 to n do write (a[i]) ;

    writeln;

    for i: = 0 to n do write (b[i]) ;

    writeln;

    for i: = 0 to n do write (c[i]) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в Паскале и объясните, как это делается Сложить два 15-ти значных целых числа. При этом используют тип integer. Т. е. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Переведите программу в Free Pascal var A: Array [1 ... 100] of integer; size: integer; Even: integer; notEven: integer; begin Write ('Set size A : ') ; Read (size) ; for i:integer : = 1 to size do begin Write ('Set A[', i, ']: ') ; Read (A[i]) ; end;
Ответы (2)
1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов. 2. Написать прогрумму, которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.
Ответы (1)
можете объяснить за что отвечает xsearch? program c4; var n: integer; x, y: integer; xmin, xmax: integer; xsearch: boolean; ymin, ymax: integer; i: integer; s: real; begin xsearch : = true; xmin : = 0; xmax : = 0; ymin:=0; ymax : = 0; readln (n) ;
Ответы (1)
Выберите пункт где описан массив из 15 чисел в Паскале Выберите один из 4 вариантов ответа: 1) a: array[5 ... 15] of integer; 2) a: array[5 ... 19] of integer; 3) a: array[0 ... 15] of integer; 4) a: array[15] of integer;
Ответы (1)
Program n_6; var i, x, y, z:integer; m:array[1 ... n] of integer = (1,2,3,4,5,6,7,8,9,10) ; procedure nod (a, b:integer; var c:integer) ; begin if a>b then a:=a-b else b:=b-a; randomize; for i:=1 to n do x:=m[1]; for i:=2 to n do begin m[i]:=random;
Ответы (1)