Задать вопрос
18 февраля, 10:11

Дана последовательность чисел а1, а2, ..., а15, упорядоченная по возрастанию, и число n1, не равное ни одному из чисел последовательности, и такое что а1
Определить сумму последовательности, меньших n1.

+4
Ответы (1)
  1. 18 февраля, 11:17
    0
    Program z;

    var a:array [1 ... 15] of integer; i, k, s, j, n:integer;

    begin

    writeln ('Начальная последовательность') ;

    for i:=1 to 15 do

    begin

    a[i]:=random (1,100) ;

    write (a[i], ' ') ;

    end;

    for j:=1 to 14 do

    for i:=1 to 14 do

    if a[i]>a[i+1] then

    begin

    k:=a[i];

    a[i]:=a[i+1];

    a[i+1]:=k

    end;

    writeln;

    writeln ('Отсортированная последовательность') ;

    for i:=1 to 15 do

    write (a[i], ' ') ;

    writeln;

    write ('Введите N (а[1]
    read (n) ;

    for i:=1 to 15 do

    begin

    if (a[i]=n) or (a[1]>n) or (a[15]
    begin

    while (a[i]=n) or (a[1]>n) or (a[15]
    begin

    writeln ('Ошибака! Число N не длжно совпадать с элементами последвовательности и а[1]
    write ('Введите N (а[1]
    end;

    end;

    if a[i]
    end;

    write ('Cумму последовательности меньших N = ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность чисел а1, а2, ..., а15, упорядоченная по возрастанию, и число n1, не равное ни одному из чисел последовательности, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Дана последовательность целых чисел. Прищнак окончания ввода - число 0 (элементом последовательности не считается). В последовательности как минимум одно число. Написать программу, определяющую, является ли последовательность чисел возрастающей.
Ответы (1)
Программа это- a) Аналог оригинала, отражающий некоторые его характеристики б) Объект в виде совокупности данных, хранящихся во внешней памяти компьютера в) Упорядоченная последовательность команд, необходимых компьютеру для решения поставленной
Ответы (1)