Задать вопрос
1 марта, 10:36

Даны три различных целых числа. Определить какое из них (первое, второе, третье) а) самое маленькоеб) является средним (средним назовем число которое больше нам меньшего из данных чисел, но меньше наибольшего)

+4
Ответы (2)
  1. 1 марта, 10:54
    0
    Решение:

    Даны три различных целых числа: a=17, b = 10, c=6.

    Наибольшее a>b

    a>c

    Наименьшее c
    c
    Среднее b
    b>c

    Тебе код нужен?
  2. 1 марта, 14:29
    0
    По моему так:

    program p;

    var

    a, b, c:integer;

    begin

    writeln ('первое число:') ;

    readln (a) ;

    writeln ('второе число:') ;

    readln (b) ;

    writeln ('третие число:') ;

    readln (c) ;

    if (a>b) and (a>c) then

    writeln ('Первое число является наибольшим') ;

    if (a>b) and (a
    writeln ('Первое число является средним') ;

    if (a
    writeln ('Первое число является наимешим') ;

    if (b>a) and (b>c) then

    writeln ('Второе число является наибольшим') ;

    if (b>a) and (b
    writeln ('Второе число является средним') ;

    if (b
    writeln ('Второе число является наимешим') ;

    if (c>b) and (c>a) then

    writeln ('Третие число является наибольшим') ;

    if (c>b) and (c
    writeln ('Третие число является средним') ;

    if (c
    writeln ('Третие число является наимешим') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны три различных целых числа. Определить какое из них (первое, второе, третье) а) самое маленькоеб) является средним (средним назовем ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны 3 различных числа. Определить, какое из них (первое, второе или третье) является средним
Ответы (1)
Максимум из 3-х чисел Даны 3 целых различных числа. Нужно определить, которое из них самое большое. Input Со стандартного устройства ввода вводится через пробел 3 целых числа, не превосходящих по модулю 10000.
Ответы (1)
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)
Составь алгоритм решения задачи: расположи три числа 4,8,2 в порядке убывания. 1) Начало 2) Сравни первое и второе числа; если первое ... второго, то поменяй их местами. 3) Сравни второе и третьего числа; если второе ...
Ответы (1)
На языке питон Даны два целых числа. Программа должна вывести число 1, если первое число больше второго, число 2, если второе больше первого или число 0, если они равны. Формат ввода Вводятся два целых числа. Формат вывода Выведите ответ на задачу.
Ответы (2)