Задать вопрос
6 сентября, 21:02

Составьте программу вычисления суммы элементов одномерного массива А (N), встречающихся в этом массиве ровно один раз.

+5
Ответы (2)
  1. 6 сентября, 21:18
    0
    На Паскале:

    program Program1;

    var i, j, n, k: integer;

    var result: real;

    var array1: array [1 ... 255] of real;

    begin

    result : = 0;

    write ('Введите значение N (не более 255) : ') ;

    readln (n) ;

    for i : = 1 to n do

    begin

    write ('Введите значение ', i, ' элемента массива: ') ;

    readln (array1[i]) ;

    end;

    begin

    writeln ('Массив, размером - ', n, ' элементов (а) : ') ;

    for i : = 1 to n do write (array1[i], ' ') ;

    writeln;

    end;

    for i:=1 to n do

    begin

    k : = 0;

    for j:=1 to n do

    if array1[i] = array1[j] then k : = k + 1;

    if k = 1 then result : = result + array1[i];

    end;

    writeln ('Сумма уникальных элементов массива = ', result) ;

    end.
  2. 6 сентября, 22:43
    0
    Int k=0, sum=0;

    for (int i; i
    {

    for (int j; j
    {

    if (a[i] = = a[j])

    k++;

    }

    if (k = = 1)

    sum + = a[i];

    k=0;

    }

    На C# как-то так будет выглядеть.

    Смысл в двойном цикле for, который проходится по массиву и заносит в переменную k количество первого взятого элемента и т. д., затем если условие выполняется суммирует.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу вычисления суммы элементов одномерного массива А (N), встречающихся в этом массиве ровно один раз. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)