Задать вопрос
28 декабря, 00:58

Cоздать два одномерных массива разного размера массив максимального элемента которого большее упорядочить по убыванию (На Паскале)

+1
Ответы (1)
  1. 28 декабря, 03:28
    0
    Program gt;

    var a, b:array[1 ... 1000]of integer;

    n, m, i, j, k, l, max1, max2:integer;

    begin

    randomize;

    n:=random (100) + 1;

    m:=random (100) + 1;

    max1:=-1;

    for i:=1 to n do

    begin

    a[i]:=random (1000) ;

    if (a[i]>max1) then max1:=a[i];

    end;

    max2:=-1;

    for i:=1 to m do

    begin

    b[i]:=random (1000) ;

    if (b[i]>max2) then max2:=b[i];

    end;

    if (max1>max2) then begin

    for i:=1 to n-1 do

    begin

    for j:=1 to n-1 do

    begin

    k:=a[j]; l:=a[j+1];

    if (a[j]>a[j+1]) then begin

    a[j]:=l;

    a[j+1]:=k;

    end;

    end;

    end;

    end;

    if (max2>max1) then begin

    for i:=1 to m-1 do

    begin

    for j:=1 to m-1 do

    begin

    k:=b[j]; l:=b[j+1];

    if (b[j]>b[j+1]) then begin

    b[j]:=l;

    b[j+1]:=k;

    end;

    end;

    end;

    end;

    for i:=1 to n do

    begin

    write (a[i],' ') ;

    end;

    writeln;

    for i:=1 to m do

    begin

    write (b[i],' ') ;

    end;

    end.

    здесь у меня случайный набор

    n-кол-во элементов в 1 массиве

    m-кол-во элементов в 2 массиве

    a[i]-первый массив

    max1-максимальный элемент 1-вого массива

    и так же для 2-го массива
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Cоздать два одномерных массива разного размера массив максимального элемента которого большее упорядочить по убыванию (На Паскале) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
1. Даны два одномерных массива разной размерности. Для каждого из заданных одномерных массивов выполнить: последовательно переписать в другой массив отрицательные элементы начального массива. с применение подпрограмм и процедур желательно
Ответы (1)