Задать вопрос
3 июля, 20:53

Решить в целых числах уравнение a x + b = 0. Вводятся 2 числа: a и b. Необходимо вывести все решения, если их число конечно, "NO" (без кавычек), если решений нет, и "INF " (без кавычек), если решений бесконечно много. Нужно решить в pascal ABC

+3
Ответы (1)
  1. 4 июля, 00:39
    0
    Var a, b:integer;

    x:real;

    begin

    writeln ('введи числа a и b') ;

    readln (a, b) ;

    if a=0 then writeln ('No')

    else begin

    x:=b / (-1*a) ;

    writeln (x:5:2) ;

    end;

    end.

    Я не представляю чисто с математической точки зрения, как тут может быть несколько вариантов, а уж тем более множество. Если приведешь примеры, я перепишу код
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить в целых числах уравнение a x + b = 0. Вводятся 2 числа: a и b. Необходимо вывести все решения, если их число конечно, "NO" (без ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить в целых числах уравнение (ax + b) : (cx + d) = 0. Входные данные Вводятся 4 числа: a, b, c и d; c и d не равны нулю одновременно.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)