Задать вопрос
18 апреля, 06:38

1) Дано число А. Определить, положительное, отрицательное оно или равно 0.

2) Определить, принадлежит ли меньшее из чисел M и N промежутку [-20; 10).

+4
Ответы (2)
  1. 18 апреля, 07:39
    0
    1)

    var

    A:integer;

    Begin

    Readln (a) ;

    If a0 then

    If a<0 then writeln ('a0')

    Else writeln ('a=0') ;

    End.

    2)

    Var

    A, M, n:integer;

    Begin

    readln (m) ;

    readln (n) ;

    If m=n then writeln ('error') else

    If m>n then a:=n else a:=m;

    If (-20<=a) and (a<10) then writeln ('Yes') else

    Writeln ('No') ;

    End.
  2. 18 апреля, 10:31
    0
    Var m, n, x, y: integer;

    begin

    write ('Введите число M: ') ; read (m) ;

    write ('Введите число N: ') ; read (n) ;

    if (m
    if (m>=-20) and (m<10) then writeln ('Число M входит в промежуток [-20; 10) ') else writeln ('Число M не входит в промежуток [-20; 10) ') ;

    end

    else begin

    if (n>=-20) and (n<10) then writeln ('Число N входит в промежуток [-20; 10) ') else writeln ('Число N не входит в промежуток [-20; 10) ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Дано число А. Определить, положительное, отрицательное оно или равно 0. 2) Определить, принадлежит ли меньшее из чисел M и N промежутку ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Составить программу, которая запрашивает целое число, не равное нулю, сообщает, положительное оно или отрицательное. и при этом положительное число уменьшает в 2 раза, а отрицательное возводит в квадрат.
Ответы (1)
Помогите решить задания: (делать в условном операторе) 1. Даны 2 числа а и b, найти разность между большим и меньшим из этих чисел. 2.
Ответы (1)
дано число. если это число положительное, то вывести что оно положительное. в противном случае вывести, что оно отрицательное
Ответы (2)
Напишите программы, для Паскаля. 1. Дано число Х. Определить положительное число или отрицательное. 2. Даны три целых числа. Определить количество положительных чисел. 3. Дано число Х. Определить чётное число или нечётное.
Ответы (2)