Задать вопрос
2 мая, 23:10

вычислить число пи через разложение в ряд

взяв 500 слагаемых

+2
Ответы (1)
  1. 2 мая, 23:53
    0
    Если power изучали, то можно так:

    var

    k:integer;

    p:real;

    begin

    for k:=1 to 500 do

    p:=p+power (-1, k+1) / (2*k-1) ;

    writeln ('Pi/4 = ', p)

    end.

    Если не изучали, пиши, сделаю по-другому.

    Версия для Турбо:

    program rd;

    var

    k, z:integer;

    p:real;

    begin

    z:=1;

    for k:=1 to 500 do

    begin

    p:=p+z / (2*k-1) ;

    z:=-z

    end;

    writeln ('Pi/4 = ', p)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «вычислить число пи через разложение в ряд взяв 500 слагаемых ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Установи закономерность. впиши недостающие числа в задании пирамидка первый ряд 2 5 3 4 второй ряд 7?? третий ряд? 11 4-й ряд?
Ответы (2)
Зал кинотеатра вмещает 35 рядов кресел по 40 мест в ряду. Стоимость билетов: с 1 по 10 ряд=25 копеек; с 11 по 20 ряд=40 копеек; с 21 по 35 ряд=50 копеек. Составить алгоритм вычесления общей стоимости билетов, если зал заполнен
Ответы (1)
Вася хочет представить число 2018 в виде суммы кубов натуральных чисел, содержащих наименьшее количество слагаемых. Помогите ему это сделать. В качестве ответа выведите слагаемые суммы в порядке возрастания, разделяя их одинарными пробелами.
Ответы (1)
Составить программу, определяющую результат гадания на ромашке - "любит - не любит", взяв за исходное данное количество лепестков n.
Ответы (1)
закодировать своё имя и фамилию взяв в качестве кляча своё отчество (Челнокова Екатерина Романовна) вот моё имя, фамилия, отчество.
Ответы (1)