Задать вопрос
8 ноября, 17:36

Чиполлино построил домик и хочет уложить пол на кухне плиткой. Чиполлино хочет купить плитку максимально возможного размера. Сколько потребуется плиток для укладки пола размером MxN, если резать плитку на части Чиполлино не умеет.

Входные данные: MxN - целые числа, размер пола.

Выходные данные: Целое число - кол-во плиток.

+2
Ответы (2)
  1. 8 ноября, 20:09
    0
    Program gt1;

    label 3,9;

    var m, n, q, r, w, z, t:longint;

    begin

    read (m, n) ;

    w:=m;

    t:=n;

    3:

    q:=m div n;

    r:=m mod n;

    if (r=0) then goto 9;

    m:=n;

    n:=r;

    goto 3;

    9:

    z: = (w div n) * (t div n) ;

    write (z) ;

    end.
  2. 8 ноября, 20:56
    0
    VB.

    Dim m, n as integer

    m=InputBox ("Введите m")

    n=InputBox ("Введите n")

    MsgBox ("Количество необходимых плиток - " & m*n)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Чиполлино построил домик и хочет уложить пол на кухне плиткой. Чиполлино хочет купить плитку максимально возможного размера. Сколько ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Написать на Паскале Четные числа Входные данные Вводятся целые числа a и b. Гарантируется, что a не превосходит b Выходные данные Выведите (через пробел) все четные числа от a до b (включительно). входные данные 2 5 выходные данные 2 4
Ответы (1)