Задать вопрос
23 ноября, 23:56

помогите написать задачу на с++

Хулиганы Первый

и Второй очень не любят доску почёта своей школы. Поэтому они решили наглым

образом украсть оттуда школьную стенгазету, сделанную отличниками, и порвать на

части. Первый хулиган брал кусочек газеты и рвал его на 4 части, а Второй

хулиган - на 7. Однако очень скоро дежурные нашли N кусочков этой

газеты. Им стало интересно, все ли кусочки они нашли. Помогите им.

Дежурные так

старались, что упустить из виду они могли не более 2 кусочков.

Входные данные

Натуральное число N < 1018.

Выходные данные

Выведите

"Yes", если все кусочки

найдены, и "No" - в

противном случае.

Пример

Вход Выход

4 Yes

67 Yes

11 No

+2
Ответы (1)
  1. 24 ноября, 01:41
    0
    Вот, правда немного запутано - не стал задумываться об элегантности кода. Алгоритм, вроде как, нашёл (N-1/b).

    #include

    using namespace std;

    int main ()

    {

    int n, b=3, x;

    start:

    setlocale (LC_ALL, "Russian") ;

    cout << "Введите число собранных кусочков: ";

    cin >> n;

    x=n-1;

    if (x%b==0)

    cout << "Yes" << endl;

    else

    cout << "No" << endl;

    goto start;

    system ("pause") ;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «помогите написать задачу на с++ Хулиганы Первый и Второй очень не любят доску почёта своей школы. Поэтому они решили наглым образом украсть ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
4. В городской библиотеке на компьютере в каталоге Периодика хранился файл Газеты. xls. Этот файл переместили в каталог, в котором непосредственно расположен файл с полным именем Р:/Газеты/Архив/Газеты. с1 ос.
Ответы (1)