Задать вопрос
10 апреля, 13:59

Дано: x, y, z. Вычислить количество чисел, кратных 5. Составить БСА и текст программы.

+1
Ответы (1)
  1. 10 апреля, 17:37
    0
    Var x, y, z:integer;

    n, m, k:word;

    begin

    readln (x, y, z) ;

    if x mod 5 = 0 then

    n:=1;

    if x mod 50 then

    n:=0;

    if y mod 5 = 0 then begin

    m:=1;

    m:=n+m;

    end;

    if y mod 5 0 then begin

    m:=0;

    m:=n+m;

    end;

    if z mod 5 = 0 then begin

    k:=1;

    k:=k+m;

    end;

    if z mod 5 0 then begin

    k:=0;

    k:=k+m;

    end;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано: x, y, z. Вычислить количество чисел, кратных 5. Составить БСА и текст программы. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Какие программы относятся к прикладным программам? A. Программы общего назначения. B. Специальные профессиональные программы. C. Языки программирования. D. Сервисные программы. E. Операционные системы.
Ответы (1)
Антивирусные программы-это 1. программы сканирования и распознавания 2. программы выявляющие и лечащие компьютерные вирусы 3. программы только выявляющие вирусы 4. программы-архиваторы разархиваторы
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
12. Офисные программы - это а) программы для управления работой компью-тера; б) программы для подготовки документов; в) программы для борьбы с вирусами.
Ответы (2)
Линейная структура построения программы подразумевает - 1) повторение отдельных частей программы 2) последовательно выполнение всех элементов программы 3) выполнение лишь нескольких, удовлетворяющих заданному условию частей программы
Ответы (1)