Задать вопрос
25 ноября, 01:10

Найти строку двумерного массива с наименьшей суммой элементов

язык паскаль, const n=4; m=2;

+1
Ответы (1)
  1. 25 ноября, 04:39
    0
    Program naim;

    const n = 4;

    m = 2;

    var a: array [1 ... n, 1 ... m] of integer;

    s: array [1 ... n] of integer;

    i, j, min: integer;

    begin

    for i: = 1 to n do begin

    s[i]:=0;

    for j: = 1 to m do

    read (a[i, j]) ;

    writeln ('') ; end;

    for i: = 1 to n do

    for j: = 1 to m do

    s[i]:=s[i]+a[i, j];

    j:=1;

    min:=s[1];

    for i: = 2 to n do

    if s[i]
    min: = s[i];

    j:=i; end;

    writeln ('') ;

    writeln ('Номер строки с минимальной суммой: ', j) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти строку двумерного массива с наименьшей суммой элементов язык паскаль, const n=4; m=2; ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Паскаль, составьте программу для двумерного массива: Найти произведение отрицательных элементов указанной строки двумерного массива размером 4*5 целых чисел.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)