Задать вопрос
10 октября, 11:19

Составить программу, определяющую какая буква слова x (первая или последняя) чаще встречается в слове y. Паскаль!

+1
Ответы (1)
  1. 10 октября, 13:03
    0
    Var x, temp:string;

    first, last:char;

    k1, k2:integer;

    begin

    write ('X = ') ;

    readln (x) ;

    k1:=0;

    k2:=0;

    first:=x[1];

    last:=x[length (x) ];

    temp:=x;

    while (pos (first, temp) >0) do

    begin

    inc (k1) ;

    delete (temp, pos (first, temp),1) ;

    end;

    temp:=x;

    while (pos (last, temp) >0) do

    begin

    inc (k2) ;

    delete (temp, pos (last, temp),1) ;

    end;

    if (k1>k2) then writeln ('First') else

    if (k2>k1) then writeln ('Last') else

    writeln ('Equal') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, определяющую какая буква слова x (первая или последняя) чаще встречается в слове y. Паскаль! ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Какие из слов удовлетворяют следующему условию: (первая буква согласная->последняя буква согласная) U (первая буква гласная->последняя буква гласная) спорт клавиатура аэропорт яблоня буква
Ответы (2)
Какое из приведённых имён удовлетворяет логическому условию: (первая буква гласная И последняя буква согласная) ИЛИ (первая буква согласная И последняя буква гласная) ? Если таких слов несколько, укажите самое короткое из них: a. Антон b. Сережа c.
Ответы (1)
1. Напишите программу, определяющую сумму S=1+2+3+4 ... + 99 2. Напишите программу, определяющую произведение P=1*2*3*4 ... * 10 На Паскаль За ранее благодарна
Ответы (1)