Задать вопрос
7 августа, 22:48

Тема: Одномерные массивы.

В паскале в массиве даны 10 целых чисел.

Нужно найти сумму четных чисел.

+4
Ответы (1)
  1. 7 августа, 22:54
    0
    Var

    A: Array[0 ... 9] of Integer;

    i, Sm: Integer;

    begin

    Sm:=0;

    for i:=0 to 9 do

    A[i]:=Random (300) - 20;

    for i:=0 to 9 do

    if (A[i] Mod 2 = 0) then

    Sm:=Sm + A[i];

    WriteLn ('Sum = ', Sm) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Тема: Одномерные массивы. В паскале в массиве даны 10 целых чисел. Нужно найти сумму четных чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)
Подпрограммы, Pascal ABC Дано массивы А1 (N1, M1), A2 (N2, M2), A3 (N3, M3). Сформировать одномерные массивы В1, В2, В3, каждый из которых состоит из 2-ух элементов.
Ответы (1)
Дано массивы А1 (N1, M1), A2 (N2, M2), A3 (N3, M3). Сформировать одномерные массивы В1, В2, В3, каждый из которых состоит из 2-ух элементов.
Ответы (1)
Вычислить сумму и разность двух одномерных массивов содержащих 20 элементов. В массиве суммы найти максимальный элемент и его индекс. В массиве разности найти минимальный элемент и его индекс. Исходные массивы ввести при помощи случайных чисел.
Ответы (1)
Тема одномерные массивы Написать программу в паскале: 1. Массив на 15 значений заполнен случайными числами посчитать количество нечетных значений 2.
Ответы (1)