Задать вопрос
10 мая, 21:19

Написать программу на языке паскаль (разветвляющийся алгоритм) :

1) F=x2-3 (икс в квадрате минус три), x2=x*x (x в квадрате равен x умножить на x)

2) S=1/2ab (одна вторая а б)

3) С=a2-b2 (а в квадрате минус б в квадрате)

+2
Ответы (2)
  1. 10 мая, 23:00
    0
    Var x, f, s, c, a, b:real;

    begin

    write ('X = ') ;

    readln (x) ;

    write ('A = ') ;

    readln (a) ;

    write ('B = ') ;

    readln (b) ;

    f:=x*x-3;

    s:=a*b/2;

    c:=a*a-b*b;

    writeln ('F=', f:3:2,' S=', s:3:2,' C=', c:3:2) ;

    end.
  2. 10 мая, 23:56
    0
    1) Не разветвление)

    program xizt;

    uses crt;

    var x, f:real;

    begin

    writeln ('введите х') ;

    readln (x) ;

    f:=sqr (x) - 3;

    writeln (f) ;

    end.

    2) program xizt;

    uses crt;

    var a, b, s:real;

    begin

    writeln ('введите a, b через пробел') ;

    readln (a, b) ;

    s:=1/2*a*b

    writeln (s) ;

    end.

    3) program xizt;

    uses crt;

    var a, b, c:real;

    begin

    writeln ('введите a, b через') ;

    readln (a, b) ;

    c:=sqr (a) - sqr (b) ;

    writeln (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на языке паскаль (разветвляющийся алгоритм) : 1) F=x2-3 (икс в квадрате минус три), x2=x*x (x в квадрате равен x ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
исключи из предложенных сочетаний слов те, которые невозможны в информатике: 1) линейный алгоритм 2) прямой алгоритм 3) циклический алгоритм 4) разветвляющийся алгоритм
Ответы (2)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Что такое алгоритм? Линейный алгоритм? Разветвляющийся алгоритм?
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)