Задать вопрос
26 мая, 19:20

Дана последовательность целых чисел а1, а2, ..., а20. верно элементы последовательности равны собой. нужно написать программу на паскале с циклом

+1
Ответы (1)
  1. 26 мая, 22:37
    0
    Var a: array [1 ... 20] of integer;

    i: integer;

    begin

    for i : = 1 to 20 do

    readln (a[i]) ;

    for i : = 1 to 20 do

    if (a[i] a[1]) then

    begin

    writeln ('Неверно') ;

    exit;

    end;

    writeln ('Верно') ;

    end.

    Надеюсь, я правильно понял задачу, а то иногда не разобрать ... Тут вначале надо 20 чисел ввести, а потом она проверяет, верно ли, что они все равны)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность целых чисел а1, а2, ..., а20. верно элементы последовательности равны собой. нужно написать программу на паскале с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Если выполнения алгоритма заканчивается, когда условие цикла становится истинным, то он называется: 1) циклом с предусловием 2) бесконечность 3) циклом n-раз 4) циклом с постусловием
Нет ответа
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Дана последовательность целых чисел. Прищнак окончания ввода - число 0 (элементом последовательности не считается). В последовательности как минимум одно число. Написать программу, определяющую, является ли последовательность чисел возрастающей.
Ответы (1)
Написать программу в Паскале. Используя операторы цикла и условия, написать программу, которая из введенных N чисел: 1) Находит и выводит на экран все двухзначные числа, кратные 10 (с циклом mod). 2) Найти сумму всех чисел больше 10.
Ответы (1)