Задать вопрос
1 июля, 21:19

Даны два одномерных массива. Написать функцию, которая определит, среднее арифметическое значение какого массива больше

+5
Ответы (1)
  1. 2 июля, 00:59
    0
    Function srarifm;

    var mas1, mas2 : array[1 ... 100000] of longint;

    i, n1, n2 : longint;

    sum1, sum2:real;

    begin

    sum1:=0; sum2:=0;

    for i:=1 to n1 do begin

    sum1:=sum1+mas1[i];

    end;

    for i:=1 to n2 do begin

    sum2:=sum2+mas2[i];

    end;

    if sum1/n1>sum2/n2 then writeln (1) else if sum2/n2>sum1/n1 then writeln (2) else writeln (=)

    end;

    Ну вроде так ... Хотя ничего не обещаю)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны два одномерных массива. Написать функцию, которая определит, среднее арифметическое значение какого массива больше ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Даны два одномерных массива разной размерности. Для каждого из заданных одномерных массивов выполнить: последовательно переписать в другой массив отрицательные элементы начального массива. с применение подпрограмм и процедур желательно
Ответы (1)
Даны два одномерных массива разной размерности. Для каждого из заданных одномерных массивов выполнить преобразование массива так: все его элементы, большие девяти заменить числом девять, все его элементы, меньшие пяти заменить числом пять, а все
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Создать два одномерных массива, состоящих из целых чисел. Элементы массива вводятся с клавиатуры. В первом массиве найти номер первого нечетного элемента массива. Во втором массиве найти первый четный элемент массива.
Ответы (1)