Задать вопрос
14 сентября, 10:49

Нужен программный код для Паскаль.

Для последовательности целых чисел а, b, c все четные числа разделите на 2. Нечетные оставьте без изменений.

+3
Ответы (1)
  1. 14 сентября, 13:59
    0
    Var a, b, c:integer;

    begin

    readln (a, b, c) ;

    if (a mod 2 = 0)

    a:=a div 2;

    if (b mod 2 = 0)

    b:=b div 2;

    if (c mod 2 = 0)

    c:=c dic 2;

    writeln (a,' ', b,' ', c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужен программный код для Паскаль. Для последовательности целых чисел а, b, c все четные числа разделите на 2. Нечетные оставьте без ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1. Найти разность 31 (10) - 16 (10) в восьмибитном представлении. Прямой код, обратный код и дополнительный код. 2. Представить число - 292 (10) в двоичном виде в шестнадцатибитном представлении в формате целого со знаком.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Задано 3 целых числа a, b, c. Узнать есть среди них хоть 1 четное. 2) Посчитать кол-во четных чисел.
Ответы (1)
Дан целочисленный массив размера N. Увеличить все нечетные числа содержащиеся в массиве на исходное значение последнего нечётного числа. Если нечётные числа в массиве отсутствуют, то оставить массив без изменений
Ответы (1)