Задать вопрос
6 мая, 13:27

Помогите написать программу в Паскале и блок-сxему.

Задача: ввести 10 чисел, если число положительное, то от него отнять 0,5, если число отрицательное, то ничего с ним не делать. Вывести результат на экран.

+5
Ответы (1)
  1. 6 мая, 14:56
    0
    Var a, b, i: real;

    begin

    b:=0,5;

    for i = 1 to 10 do

    begin

    readln (a) ;

    if a<0 then

    writeln (a)

    else

    a:=a-b;

    writeln (a) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в Паскале и блок-сxему. Задача: ввести 10 чисел, если число положительное, то от него отнять 0,5, если число ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Помогите с ИКТ, 9 класс, Паскаль! #1 Ввести число, если оно отрицательное, найти его квадрат и вывести результат, иначе вывести на экран число положительное. #2 Ввести значение Х, вычислить значение Z, где Z=Х^2 (Х во второй степени) при х >0.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)