Задать вопрос
24 октября, 21:05

Петр, когда едет на турнир, всегда берет с собой шоколадку прямоугольной формы для восстановления сил. Определите скольким друзьям достанется шоколадка, если ее сначала разломали N раз, а затем каждую образовавшуюся часть поделили K раз.

Входные данные:

Входной поток содержит единственную строку из двух цифр N и K разделенных пробелом (0 ≤ N, K ≤ 2147483647)

Выходные данные:

Выходной поток содержит единственное целое число - количество кусочков шоколадки.

+3
Ответы (1)
  1. 24 октября, 22:08
    0
    Var s, n, k, p:integer;

    begin

    write ('введите n и k: ') ;

    read (n, k) ;

    if n>=0 then s:=s+1;

    if (k=0) then s:=s+1;

    if s=2 then p: = (n+1) * (k+1) else writeln;

    write (p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Петр, когда едет на турнир, всегда берет с собой шоколадку прямоугольной формы для восстановления сил. Определите скольким друзьям ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Дано натуральное число N. Напишите функцию (Pascal), определяющую количество нулей среди всех цифр числа N. Входные данные Задано единственное число N Выходные данные Необходимо вывести количество нулей среди всех цифр числа N.
Ответы (1)