Задать вопрос
15 ноября, 17:42

Помогите в программе Pascal (линейный, ветвление и циклический)

Разработайте схему алгоритма

для вычисления произведения P = (-1) * 2 * (-3) * 4 * (-5)

* ... * n. Используйте два цикла: один для вычисления произведения нечетных

чисел P1,

второй - для вычисления произведения четных чисел P 2.

+3
Ответы (1)
  1. 15 ноября, 19:56
    0
    Var

    a, n, x, p1, p2:integer;

    begin

    readln (n) ;

    x:=-1;

    a:=0;

    p1:=1;

    p2:=1;

    while abs (a)
    x:=x * (-1) ;

    a: = (abs (a) + 1) * x * (-1) ;

    if abs (a) mod 2=0 then

    p2:=p2*a

    else

    p1:=p1*a;

    end;

    writeln (p1) ;

    writeln (p2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите в программе Pascal (линейный, ветвление и циклический) Разработайте схему алгоритма для вычисления произведения P = (-1) * 2 * ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) приведите пример исполнителя алгоритма. 2) Должен ли составитель алгоритма знать, кто будет являться исполнителем алгоритма? 3) Перечислите свойства алгоритма. 4) Поясните значение свойства алгоритма "определенность".
Ответы (1)
Сколько раз будет выполнено тело цикла? А. for i:=-5to5 do тело цикла; В. for i:=6 to 2 do тело цикла; С. for i: = 3to 3 do тло цикла; D. for i:=3 downto 4 do тело цикла E. for i : = 3 downto 1 do тело цикла
Ответы (1)
Для чего используются команды цикла? Как записывается команда цикла FOR? Как в цикле записать команду присваивания, чтобы она вычисляла сумму чисел? Количество?
Ответы (2)
Помогите решить 1 написание блок-схему цикла для 2 дан линейный алгоритм а:=14; b:=8+a mod 6; a:=b*3 div 3 Чему равно значение переменных a и b после выполнения алгоритма 3 определите значение переменной после выполнения фрагмента алгоритма f:=
Ответы (1)
Формальное исполнение алгоритма - это? Выберите один ответ: A. Разбиение алгоритма на конкретное число команд и их пошаговое исполнение B. Исполнение алгоритма конкретным исполненителем с полной записью его рассуждений C.
Ответы (1)