Задать вопрос
2 февраля, 17:03

Помогите решить задачу в паскаль!

Последовательность состоит из натуральных чисел и завершается числом 0. Всего вводится не более 10000 чисел (не считая завершающего числа 0). Определите, сколько элементов этой последовательности равны ее наибольшему элементу. Числа, следующие за числом 0, считывать не нужно.

у меня есть такой вариант но нужен еще один

readln (a) ; begin

if a > 0 then

if (max = 0) or (a > max) then

begin

max : = a;

k : = 1 end

else if a = max then

inc (k) ;

end;

until a=0;

write (k) ;

end.

+3
Ответы (1)
  1. 2 февраля, 20:07
    0
    Var t, i, x, max:integer;

    begin

    max:=0; t:=0;

    repeat

    begin

    x:=0;

    read (x) ;

    if (x>0) and (x=max) then i:=i+1;

    if x>max then

    begin

    max:=x;

    i:=1;

    end;

    t:=t+1;

    end;

    until (x=1000) or (x mod 1>0) ;

    if (x0) then begin i:=-1; writeln ('Нельзя вводить ненатуральные числа') ; end;

    if i=0 then writeln ('Введён только ноль') ;

    if i>0 then writeln ('Чисел, равных максимуму: ', i) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачу в паскаль! Последовательность состоит из натуральных чисел и завершается числом 0. Всего вводится не более 10000 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Питон. Последовательность состоит из натуральных чисел и завершается числом 0. Определите, сколько элементов этой последовательности равны ее наибольшему элементу.
Ответы (1)
Где ошибка? Sub сер Dim x, y, z, f, max, min As Single x = Val (InputBox (2)) y = (InputBox (6)) z = (InputBox (10)) If x / 2 > y / 3 > z / 4 Then If x / 2 > y / 3 Then max = x / 2 Else max = y / 3 End If End If Else If y / 3 > z / 4 Then max =
Ответы (1)
Определите сумму всех элементов последовательности, завершающейся числом 0. Числа, следующие за нулем, считывать не нужно. Входные данные Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит).
Ответы (1)
Python 3 Последовательность состоит из натуральных чисел и завершается числом 0. Определите, сколько элементов этой последовательности равны её наибольшему эле- менту. (ответа в интернете - нет)
Ответы (1)
Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке.
Ответы (1)