Задать вопрос
14 октября, 19:12

Помогите написать программу в паскале: Даны две строки: S1 и S2. Можно ли из символов строки S1 составить строку S2? Регистр значения не имеет.

(например

a) S1='april', S2='may'. Ответ: false

b) S1='Rom', S2='room'. Ответ: false, т. к. буква 'o' встречается в строке S1 один раз.

c) S1='tomorrow', S2='mOtOr'. Ответ: true)

+3
Ответы (1)
  1. 14 октября, 19:50
    0
    Var

    i, n:integer;

    s1, s2:string;

    f:boolean;

    begin

    f:=true;

    writeln ('Введите первую строку') ;

    readln (s1) ;

    writeln ('Введите вторую строку') ;

    readln (s2) ;

    s1:=LowerCase (s1) ;

    s2:=LowerCase (s2) ;

    i:=1;

    repeat

    n:=pos (s2[i], s1) ;

    if n>0 then delete (s1, n, 1) else f:=false;

    i:=i+1;

    until i=length (s2) ;

    writeln (f)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в паскале: Даны две строки: S1 и S2. Можно ли из символов строки S1 составить строку S2? Регистр значения не ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Выберите логическое выражение, принимающее значение True a) (True and True) and (False or False) b) Not (True and Not False) or False c) (True or False) or Not (True and True) d) Not (True or False) and True
Ответы (1)
1. Вычислите логические выражения: not true and not false not true or not false not (true or false) not (true and false) 2. Напишите условие нахождения точки a в первом квадранте системы координат, считая ее координаты заданными X переменными x, y.
Ответы (1)
Паскаль Дана строка. Если в этом числе буква f встречается только один раз, выведите её индекс. Если она встречается два и более раз, выведите индекс её первого и последнего появления. Если буква f в данной строке не встречается, ничего не выводите.
Ответы (1)
Вася учится в школе. Недавно учитель записал на доске строку из строчных латинских букв и цифр, а Вася переписал эту строку в тетрадку. Придя домой, Вася столкнулся с проблемой в прочтении строки.
Ответы (1)
Дана строка. Найдите в этой строке второе вхождение буквы f, и выведите индекс этого вхождения. Если буква f в данной строке встречается только один раз, выведите число - 1, а если не встречается ни разу, выведите число - 2
Ответы (1)