Задать вопрос
5 декабря, 22:37

Составьте программу осуществляющую поиск однофамильцев, обучающихся в одном классе

+5
Ответы (1)
  1. 6 декабря, 01:23
    0
    uses crt;

    type uchenik=record

    fam:string[20];

    im:string[20];

    kls:string[3];

    end;

    var a:array[1 ... 100] of uchenik;

    n, i, j, k:byte;

    begin

    clrscr;

    writeln ('Сколько учеников n=') ;

    readln (n) ;

    writeln ('Введите данные о ', n,' учениках:') ;

    for i:=1 to n do

    begin writeln ('Ученик ', i) ;

    write (' Фамилия: ') ;

    readln (a[i]. fam) ;

    write (' Имя: ') ;

    readln (a[i]. im) ;

    write (' Класс (год+буква, 11 а) : ') ;

    readln (a[i]. kls) ;

    end;

    writeln ('Однофамильцы в одном классе:') ;

    k:=0; for i:=1 to n-1 do for j:=i+1 to n do

    if (a[i]. fam=a[j]. fam) and (a[i]. kls=a[j]. kls) then

    begin

    k:=1;

    writeln (a[i]. kls,' ', a[i]. fam,' ', a[i]. im,' ', a[j]. fam,' ', a[j]. im) ;

    end;

    if k=0 then write ('Однофамильцев в одном классе нет!') ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу осуществляющую поиск однофамильцев, обучающихся в одном классе ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Какого типа информации в поисковых системах не существует: а) поиск по любому из слов в) поиск по всем словам с) поиск по синонимам д) поиск точно по фразе
Ответы (1)
Написать программу, осуществляющую заполнение и вывод на экран массива состоящего из 10 элементов последовательностью 1,3,5,7, ... (Удвоенный порядковый номер минус 1)
Ответы (1)
Составить программу, осуществляющую перевод величин из радианной меры в градусную или наоборот. Программа должна запрашивать, какой перевод надо осуществить, и выполнять указанное действие.
Ответы (1)
10. Составить программу, осуществляющую ввод числовых переменных. При вводе положительного числа вывести информацию: "Число больше ноля", при вводе отрицательного числа - "Число меньше ноля", при вводе ноля - "Вы ввели ноль".
Ответы (1)
В turbo pascal: Дано трехзначное число. Написать программу осуществляющую вывод этого числа в обратном порядке
Ответы (1)